The issue with the upstream service provider has been resolved.
All sites are restored to full function.
Sites that had to undergo Disaster Recovery steps will have these finalized and restored to normal during the relevant maintenance windows for those sites.
Apologies for the inconvenience StarRez
Posted May 12, 2026 - 03:03 UTC
Monitoring
The upstream provider has completed the fix and we are seeing recovery across all impacted sites.
StarRez Engineers are continuing to monitor the situation.
- Updates within the next hour or as warranted.
Apologies for the inconvenience StarRez
Posted May 12, 2026 - 01:46 UTC
Update
The service disruption is still ongoing within this region.
StarRez Engineers are actively in the process of executing our Disaster Recovery plan for impacted customers.
The upstream provider has identified the root cause and are working on a fix for the issue.
- Updates within the next hour or as warranted.
Apologies for the inconvenience StarRez
Posted May 12, 2026 - 00:58 UTC
Update
The service disruption is still ongoing within this region.
StarRez Engineers are actively in the process of executing our Disaster Recovery plan for impacted customers.
The upstream provider is continuing their investigation into this incident. Further updates will be shared as more information becomes available.
- Updates within the next hour or as warranted.
Apologies for the inconvenience StarRez
Posted May 11, 2026 - 23:37 UTC
Update
The service disruption is still ongoing within this region.
StarRez Engineers are actively in the process of executing our Disaster Recovery plan for impacted customers.
Customers are starting to come online as this process completes.
- Updates within the next hour or as warranted.
Apologies for the inconvenience StarRez
Posted May 11, 2026 - 22:23 UTC
Update
The upstream provider is continuing their investigation into this incident. Further updates will be shared as more information becomes available.
Posted May 11, 2026 - 22:15 UTC
Update
The upstream provider is continuing their investigation into this incident. Further updates will be shared as more information becomes available.
Posted May 11, 2026 - 21:08 UTC
Update
The upstream provider is continuing their investigation into this incident. Further updates will be shared as more information becomes available.
Posted May 11, 2026 - 20:13 UTC
Update
The upstream provider is continuing their investigation into this incident. Further updates will be shared as more information becomes available.
Posted May 11, 2026 - 19:09 UTC
Update
The upstream service provider has confirmed an issue and are in the process of resolving this for our West Central US region. Further updates will be shared as more information becomes available.
Posted May 11, 2026 - 18:05 UTC
Identified
We’ve identified an issue with an upstream service provider that is impacting availability for a number of clients. We have escalated the issue with the provider to expedite remediation and are actively monitoring the situation. Further updates will be shared as more information becomes available.
Posted May 11, 2026 - 16:55 UTC
Investigating
We are aware of a service disruption currently. We are investigating the cause and will provide additional updates as possible, or within the next 60 minutes.
Posted May 11, 2026 - 15:56 UTC
This incident affected: StarRez Regions (West Central US).