Service Disruption - Database Refresh Services - Global

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 00:48 UTC

Identified

We are aware of an issue affecting Database Refreshes. We have identified the cause and our team is actively working on a fix. Further updates will be shared as they become available.

Apologies for any inconvenience,
StarRez Team
Posted Sep 17, 2025 - 22:00 UTC