The upstream provider has resolved the issue, with all customer workloads back online.
Engineers will continue to monitor and will close this incident out once stability has been confirmed.
Posted Dec 05, 2025 - 10:30 UTC
Identified
We are aware of an issue affecting access to StarRez Cloud as a result of a global outage of an upstream provider. We are assessing the impact and escalating with the provider as required
Posted Dec 05, 2025 - 09:42 UTC
Investigating
We are investigating an issue affecting all regions.
Next Update in 60 minutes or sooner if we have more information.
Posted Dec 05, 2025 - 09:18 UTC
This incident affected: StarRez Regions (Australia East, Australia Southeast, Canada Central, Canada East, Central US, East US, East US 2, France Central, North Central US, North Europe, South Africa North, South Central US, Southeast Asia, Switzerland North, UK South, UK West, West Central US, West Europe, West US, West US 2).