Service Disruption: College Pads

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Jun 13, 2026 - 00:14 UTC

Monitoring

The underlying issues have now been resolved with all customer workloads now back online.

Engineers will continue to monitor the situation.
Posted Jun 12, 2026 - 22:01 UTC

Investigating

College Pads customers are experiencing a service disruption
-Engineers are actively working to remediate the issue.
-Next update expected within 60 minutes, or as warranted by a change of events.
Posted Jun 12, 2026 - 21:26 UTC
This incident affected: College Pads (Partner Sites).