Service Disruption - THD VPN Tunnel

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 12:58 UTC

Monitoring

There was a temporary disruption affecting access to the THD VPN tunnel. Services have since been fully restored, and we are continuing to monitor the situation closely.
Posted Apr 28, 2026 - 11:54 UTC
This incident affected: The Housing Director Cloud (The Housing Director Cloud Services).