Service Disruption - THD SFTP service

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 20:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2026 - 18:39 UTC

Identified

The issue has been identified and engineers are remediating.
The next update is due within 60 minutes, or as warranted by changes in events.
Posted Aug 27, 2026 - 17:52 UTC

Update

Engineers are actively working to remediate the issue.  
Next update expected within 60 minutes, or as warranted by a change of events.
Posted Aug 27, 2026 - 17:05 UTC

Investigating

THD customers using the SFTP server data-03.datacenter.adirondacksolutions.com are experiencing a service disruption.
Engineers are actively working to remediate the issue.
The next update is due within 60 minutes, or as warranted by changes in events.
Posted Aug 27, 2026 - 16:02 UTC
This incident affected: The Housing Director Cloud (The Housing Director Cloud Services).