THD - mail service disruption

Incident Report for StarRez Cloud

Update

The issue impacting the upstream provider has been identified, and a solution is currently being implemented.

Next update expected within 60 minutes, or as warranted by a change of events.
Posted Aug 13, 2026 - 17:04 UTC

Identified

The issue impacting the upstream provider has been identified, and a solution is currently being implemented.

Next update expected within 60 minutes, or as warranted by a change of events.
Posted Aug 13, 2026 - 16:06 UTC

Update

Our upstream provider is continuing to investigate the issue.
Posted Aug 13, 2026 - 15:29 UTC

Investigating

We're currently seeing a partial outage with outbound email for some customers. This is due to a heat-related incident at one of our upstream infrastructure providers, and their team is actively working on it.

Who's affected: Customers using THD-hosted email servers may notice emails being delayed or failing to send.

Who's not affected: Customers using their own email infrastructure or AWS SES — your email is sending normally.

Next update expected within 60 minutes, or as warranted by a change of events.
Posted Aug 13, 2026 - 14:17 UTC
This incident affects: The Housing Director Cloud (The Housing Director Cloud Services).