Service Disruption - South Central US

Incident Report for StarRez Cloud

Resolved

Services in the South Central US region have remained stable and performant for the past hour. The incident is now considered resolved.
Posted Oct 23, 2025 - 19:02 UTC

Monitoring

Services in the affected region are returning to normal. We are closely monitoring the situation to ensure continued stability.

Next update will be provided within 2 hours, or sooner if circumstances change.
Posted Oct 23, 2025 - 18:02 UTC

Identified

Preventative action is now being taken to prevent any further impact to customers within this region.

- Next update as warranted by a change of events.
Posted Oct 23, 2025 - 17:42 UTC

Investigating

We are seeing backend instability in the South Central US region causing a service disruption to customer applications
- Engineers are actively working with our backend vendor to determine the root cause
- Next update expected within 60 minutes, or as warranted by a change of events.
Posted Oct 23, 2025 - 17:27 UTC
This incident affected: StarRez Regions (South Central US).