Service Disruption - MFA and Email Delivery - Global

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 08:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Jan 23, 2026 - 06:00 UTC

Monitoring

We are aware of an ongoing Microsoft 365 outage that is affecting email delivery to Outlook mailboxes.

This is a downstream issue within Microsoft 365 and is separate from StarRez Cloud. As a result, some customers may experience delays or failures in receiving MFA-related emails.

We are monitoring the situation closely and will provide updates as more information becomes available.

Further details are available via Microsoft’s status page:
https://status.cloud.microsoft/

Apologies for any inconvenience caused,
StarRez Team
Posted Jan 22, 2026 - 23:26 UTC

Investigating

We are aware of an ongoing Microsoft 365 outage that is affecting email delivery to Outlook mailboxes.

This is a downstream issue within Microsoft 365 and is separate from StarRez Cloud. As a result, some customers may experience delays or failures in receiving MFA-related emails.

We are monitoring the situation closely and will provide updates as more information becomes available.

Further details are available via Microsoft’s status page:
https://status.cloud.microsoft/

Apologies for any inconvenience caused,
StarRez Team
Posted Jan 22, 2026 - 23:25 UTC
This incident affected: StarRez Core Functionality (Email Sending).