Service Disruption - Adobe Sign Customers

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 12:47 UTC

Monitoring

A fix has been implemented with all sites functionality restored.
Posted Mar 27, 2025 - 12:08 UTC

Identified

We have identified an issue causing customers to lose Adobe Sign functionality.
Customers with Adobe Sign and vanity domains on their Portalx will have lost both Adobe Sign and vanity domain functionality.

Engineers are currently rolling out a fix for this issue with some sites functionality already restored
Posted Mar 27, 2025 - 11:57 UTC
This incident affected: StarRez Regions (Canada Central, Canada East, Central US, East US, East US 2, France Central, North Central US, North Europe, South Africa North, South Central US, Switzerland North, UK South, UK West, West Central US, West Europe, West US, West US 2).