Network Degradation in East US

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 01:35 UTC

Update

We have received confirmation from our upstream vendor regarding ongoing issues and are actively monitoring the situation.
Posted Mar 19, 2025 - 00:39 UTC

Monitoring

We are currently investigating a network degradation issue in East US that may result in increased latency.

Our team is actively monitoring the situation.
Posted Mar 19, 2025 - 00:34 UTC
This incident affected: StarRez Regions (East US).