StarRez Cloud Payment Service

Incident Report for StarRez Cloud

Resolved

This incident has been resolved
Posted Mar 05, 2026 - 01:36 UTC

Monitoring

Service has recovered since applying the mitigation.

We are continuing to monitor the situation.

Next update in 60 minutes or sooner if we have more information.
Posted Mar 04, 2026 - 23:42 UTC

Identified

Engineers have applied a mitigation to address the issue and are continuing to review the situation.

Next update in 60 minutes or sooner if we have more information.
Posted Mar 04, 2026 - 23:22 UTC

Investigating

We are investigating service degradation for Cloud Payments in the US Region.

Engineers are working on mitigating the issue.

Next Update in 60 minutes or sooner if we have more information.
Posted Mar 04, 2026 - 23:12 UTC
This incident affected: StarRez Core Functionality (StarRez Cloud Payment Service).