StarRez Engineers are actively monitoring to confirm stability.
Posted Sep 10, 2026 - 23:51 UTC
Update
Our upstream service provider has mitigated the issue, and we are now seeing service response from our database tier.
StarRez Engineers are actively working on service restoration for customer sites and will provide updates once this has been completed
Posted Sep 10, 2026 - 23:44 UTC
Update
A mitigation is being attempted by the upstream provider to restore service to US East server.
StarRez Engineers are actively monitoring the situation.
Further updates will be shared as more information becomes available,
Posted Sep 10, 2026 - 22:45 UTC
Update
StarRez Engineers are working with the upstream service provider to expedite remediation and are actively monitoring the situation. Further updates will be shared as more information becomes available.
Posted Sep 10, 2026 - 22:08 UTC
Update
We’ve identified an issue with an upstream service provider that is impacting availability for all clients within the US East server.
We have escalated the issue with the provider to expedite remediation and are actively monitoring the situation. Further updates will be shared as more information becomes available.
Posted Sep 10, 2026 - 20:17 UTC
Identified
THD customers on the US East server are experiencing a service disruption. Engineers are actively working to remediate the issue. The next update is due within 60 minutes, or as warranted by changes in events.
Posted Sep 10, 2026 - 19:34 UTC
Investigating
THD customers on the US East server are experiencing a service disruption. Engineers are actively working to remediate the issue. The next update is due within 60 minutes, or as warranted by changes in events.
Posted Sep 10, 2026 - 18:48 UTC
This incident affected: The Housing Director Cloud (The Housing Director Cloud Services).