Unscheduled THD Service Outage - [all sites] [newport]

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 14:02 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 10, 2026 - 12:59 UTC

Monitoring

Service has recovered since applying the mitigation.

We are continuing to monitor the situation.

Next update in 60 minutes or sooner if we have more information.
Posted Mar 10, 2026 - 11:32 UTC

Investigating

THD customers on the Newport server might experience a service disruption.
Engineers are actively working to remediate the issue.
The next update is due within 60 minutes, or as warranted by changes in events.
Posted Mar 10, 2026 - 10:20 UTC
This incident affected: Housing Director Cloud.