All sites are now back online and stable. We will continue to monitor before resolving. -Next update as warranted by a change of events.
Posted May 08, 2026 - 10:14 UTC
Monitoring
The underlying issue has been mitigated, and customer sites are now coming back online and remaining stable. -Next update expected within 60 minutes, or as warranted by a change of events.
Posted May 08, 2026 - 09:59 UTC
Identified
The issue has been identified, and engineers are currently working to resolve this issue. Customers will continue experiencing intermittent outages whilst the work continues.
Next update expected within 60 minutes, or as warranted by a change of events.
Apologies for any inconvenience, StarRez Team
Posted May 08, 2026 - 09:12 UTC
Investigating
Customers in the East US region are currently experiencing intermittent service disruption. -Engineers are actively working to remediate the issue. -Next update expected within 60 minutes, or as warranted by a change of events.