Service Disruption - Central US

Incident Report for StarRez Cloud

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 06:13 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 26, 2026 - 06:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2026 - 06:10 UTC

Identified

The issue has been identified and engineers are remediating to bring sites back online.
-Engineers are actively working to remediate the issue.
-Next update expected within 60 minutes, or as warranted by a change of events.

Apologies for any inconvenience,
StarRez Team
Posted Jun 26, 2026 - 06:01 UTC

Investigating

Customers in the Central US region are currently having a service disruption
-Engineers are actively working to remediate the issue.
-Next update expected within 60 minutes, or as warranted by a change of events.

Apologies for any inconvenience,
StarRez Team
Posted Jun 26, 2026 - 05:53 UTC
This incident affected: StarRez Regions (Central US).