Service Disruption - West US

Incident Report for StarRez Cloud

Monitoring

The upstream service provider has implemented a remediating fix for the network infrastructure issue within the West US region. Customer site functionality will begin to be restored as the fix is rolled out

We are actively monitoring the situation. Further updates will be shared as more information becomes available.
Posted Jul 23, 2026 - 18:52 UTC

Update

The upstream service provider has confirmed a network infrastructure issue within the West US region. The upstream issue has not yet been resolved.

We are actively following disaster recovery procedures to restore availability for affected customers.

Apologies for any inconvenience,
StarRez Team
Posted Jul 23, 2026 - 18:07 UTC

Update

The upstream service provider has confirmed a network infrastructure issue within the West US region.

We are actively monitoring the situation. Further updates will be shared as more information becomes available.
Posted Jul 23, 2026 - 16:50 UTC

Identified

We’ve identified an issue with an upstream service provider that is impacting availability for all clients within the West US region.

We have escalated the issue with the provider to expedite remediation and are actively monitoring the situation. Further updates will be shared as more information becomes available.
Posted Jul 23, 2026 - 15:52 UTC

Investigating

Customers in the West US region are currently experiencing a service disruption
- Engineers are actively working to remediate the issue.
- Next update expected within 60 minutes, or as warranted by a change of events.

Apologies for any inconvenience,
StarRez Team
Posted Jul 23, 2026 - 14:56 UTC
This incident affects: StarRez Regions (West US).